Změna API pluginu

Požadavky

Postup

    1. Přihlásíme se do webové administrace
    2. V administraci si otevřeme daný Minecraft server
    3. Rozklikneme položku “Konzole” v levém menu a prohlédneme si log serveru, ve kterém se pokusíme vyhledat řádek popisující verzi MC:PE a také verzi API.
    4. Následně si otevřeme následující stránku: http://unphar.com/phar2zip, v levém menu vybereme položku Phar to Zip converter, vložíme námi stažený plugin a provedeme konverzi z .phar do .zip. Stáhneme si .zip soubor a otevřeme jej
    5. V tomto souboru nyní je několik souborů a složek. Ty nás zajímat nebudou, zajímá nás pouze soubor plugin.yml
    6. Soubor plugin.yml extrahujeme na plochu, otevřeme jej
    7. Vyhledáme v něm řádek popisující verzi API (standardně zde bude verze 1.12.0 či 2.0.0), tuto verzi přepíšeme na 3.0.0-ALPHA4
    8. Uložíme a vložíme soubor zpět do našeho zipu
    9. Opět si otevřeme stránku: http://pmt.mcpe.fun/, tentokrát však v levém menu vybereme Zip to Phar converter, nahrajeme soubor, u položky: “Stub” klepneme na tlačítko: “Use the PocketMine-MP.phar stub” a už jen klepneme na tlačítko “create phar”
      Plugin

      Spustitelný plugin pro server má koncovku .phar

    10. Stáhneme si daný soubor a nahrajeme jej do FTP do složky plugins za pomocí návodu pro nahrávání pluginů k FTP zde
      Konverze

      Tato konverze nemusí vždy fungovat. Je to dočasné řešení, než dojde k aktualizaci daného pluginu a neručíme za 100% funkčnost u každého pluginu!

Aktualizace provedena: Srpen 28, 2017

Byl tento článek užitečný?

CzechEnglish